5 users online | 5 Guests and 0 Registered

Troubleshooting "Did not find a valid PMDX-SmartBOB device" errors


So, you've got your nice new shiny PMDX-SmartBOB-USB and you can't wait to take it for a spin.   You follow the steps in the Quick Start Manual and install our plug-in.  Then you plug the SmartBOB into a USB port on your PC and fire up Mach4 and you are greeted by a couple of pop-up dialogs saying that our plug-in could not find a valid PMDX-SmartBOB device.

Bummer! What now?

Well, there are a few things you can try before contacting PMDX Support for help.

BACKGROUND: The PMDX-SmartBOB installer attempts to install a "USB Virtual COM Port" driver.  This driver is a 2nd installer package that our installer extracts and runs automatically as a background task (i.e. it is, or should be, invisible to the user).  And this virtual COM port driver installer then spawns yet another installer (yes, that's 3 levels of installers running).  That 3rd installer *is* visible.  Sometimes, for reasons that so far escape me, that 3rd installer apparently does not always install correctly.  This leaves the Virtual COM Port driver not fully functional.

***************************************************
(1) Check the "Real Easy Things" First
***************************************************

    i>Do you have any USB hubs or USB extender cables (with electronics in them) between the PC and the SmartBOB?  If you have a USB hub it *MUST* be powered from an external power supply. The SmartBOB family will not work with bus powered USB hubs.  Also, USB extender cables that have electronics in them ("signal boosters", etc.) usually act as bus powered USB hubs and will not work with the SmartBOBs.  Try connecting the SmartBOB directly to your PC.i> i>Make sure the SmartBOB is plugged into a working USB slot on your PC.  Try a different USB device in the same USB port on your PC.  Does the other device work?i> i>Try plugging the SmartBOB into a different USB port on your PC.  If you used a slot on the back of your PC, try one on the front.i> i>Try using a different USB cable, ideally one that you KNOW works with another device.i> i>If you have a PMDX-424, also make sure that it has power.i> i>All SmartBOB devices except for the PMDX-411 have a "Power On" LED. Is that lit?i> i>If the device has power and if the firmware in the SmartBOB is running, the red and green LEDs will turn on in various patterns.  The normal startup sequence is that both LEDs will turn on for a short time (maybe 1 second).  Then the green LED will flicker off and back on once.  Then the red LED will remain lit, and the green LED will produce a short flash once every 2 seconds.  If you see a different flash pattern, let us know what you see.i>

***************************************************
(2) Look in Device Manager
***************************************************

Use the Windows Device Manager to look at the list of installed devices and see if the virtual COM port is listed.  The way to get to Device Manager is different in the different versions of Windows.

WinXP: Go to the Start menu, click on "Settings" and then "Control Panel".  When the control panel is displayed, double-click on the "System" icon.  This will display the "System Properties" window.  Click on the "Hardware" tab and then the "Device Manager" button.

Win7: Go to the Start menu and select "Control Panel" (usually on the right-hand side of the start menu area).  If you see approximately 8 groups of topics, then click on "Hardware and Sound", then under the "Devices and Printers" section click on "Device Manager".  If instead of 8 groups you see lots and lots of icons, look for the icon named "Device Manager" and click on it.   Note that the icons are not always in strict alphabetical order.

Win8.1: If using a touch screen, swipe in from the right edge of the screen, and then tap Search.  If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, and then click Search.  Then in the search box enter "device manager" (without the quotes).  Then click on Device Manager in the results.  (see http://windows.microsoft.com/en-us/windows-8/where-is-device-manager)

Win10: Enter the words "Device Manager" (without the quotes) into the search box on the taskbar, then select Device Manager from the list of results. (see http://windows.microsoft.com/en-us/windows-10/open-device-manager)

Once you have the Device Manager window open, look for a line that says "Ports (COM & LPT)".  Click on the small plus sign next to that to expand this category.  You should see a line that says "STMicroelectronics Virtual COM Port", and there should NOT be a yellow question mark next to it.  This usually means that both parts of the Virtual COM Port driver installed correctly.  See the image below for an example. 

<img src="http://faq.pmdx.com/images/DeviceManager_With_VirtualCOMPort.png" width="640" height="449" />

If you see this, this go to step (4) below.

If you do not see the "STMicroelectronics Virtual COM Port" line, look just above the "Ports (COM & LPT)" line for "Other Devices".  Click on the small plus sign to expand that category.  If you see a line that says "STM32 Virtual COM Port in FS Mode", then the Virtual COM Port driver did not fully install.  See the image below for an example.

<img src="http://faq.pmdx.com/images/DeviceManager_With_BadDriverInstall.jpg" width="639" height="596" />

If you see this yellow triangle, go to step (3)

If you do not see either of these, or you see a device with a yellow question mark next to it, that means the Virtual COM Port driver is either not installed of not functioning.  Or it means that the SmartBOB device is not working.  In this case, follow he steps below to see if the problem is with the driver.

***************************************************
(3) Uninstall and re-install the driver
***************************************************

You will need to know if you have a 32-bit or 64-bit version of Windows.  If you don't know this, open the control panel as described above. If you see approx 8 groups of topics, then click on "System and Security", and then click on the sub-heading "System".  If instead of 8 groups you see lots and lots of icons, look for the icon named "System" and click on it.  Somewhere in the System Properties window it will show you whether it is a 32-bit or 64-bit version.  Note that for Windows XP, it will either say "64-bit" or nothing.  If it doesn't mention "64-bit" then you are running the 32-bit version.

Go here (http://www.pmdx.com/Downloads_Utilities/) and download either "VCP_V1.3.1_Setup.exe" for 32-bit systems, or "VCP_V1.3.1_Setup_x64.exe" for 64-bit systems.  Save the file somewhere that you can find it.

**IMPORTANT** Unplug the SmartBOB from the USB port before continuing.

Run this installer.  If it gives you a choice of "Modify", "Repair" or "Remove", select "Remove".  If you do not see these choices, then the driver is not installed at all and the installer will install it.  If you select "Remove", then once the installer has finished, run it a second time.  This will (or should) install the driver.

IMPORTANT!!!  The installer will bring up a 2nd installer during the install process.  DO NOT click on any buttons in the first installer window until the 2nd installer has finished and closed its window.  When the 2nd installer window appears, click on any "OK" or "Continue" buttons until it finishes.

Once the 2nd installer has finished AND closed its window, allow the 1st installer to finish.

Plug the SmartBOB into a USB port, open the Device Manager and see if the entry appears in the "Ports (COM & LPT)" category.  If not, contact PMDX support.  If so, try running Mach4 and see if the plug-in can talk to the SmartBOB.  If it can, have fun running your machine!  If not, proceed to step (4).

 

***************************************************
(4) Generate a SmartBOB plug-in debug log
***************************************************

If the Virtual COM Port driver shows up in Device Manager but you still see the "cannot find a valid SmartBOB device" error, then generate a debug log and send that to us.  The general steps to do this are listed here:  How to capture a debug log file and send to PMDX?

You will need to start Mach4, then click on "OK" to clear the error messages.  Once at the main Mach4 window, enable the debug log as described in the link above.  Exit Mach4, then re-start Mach4.  Then disable the debug log as described in the link above.  And finally, create a "profile package" as described in the link above, then exit Mach4.  Send the profile packet to PMDX support.

Tags: communications, install, SmartBOB, troubleshooting, USB
2018-01-13 06:37 FAQCzar

You cannot comment on this entry

Chuck Norris has counted to infinity. Twice.